Helming Jupyterhub on K3S - public proxy loadbalancer http port

I came accross a problem while deploying jupyterhub on k3s. The svclb-proxy-public service pod keeps getting stuck in pending, because the port 80 is already occupied on all nodes (single machine cluster). I tried changing the port through configuration, but it seems to have no effect on the service.

proxy:
  service:
    nodePorts:
      http: 30000
      https: 30001

Anyone any ideas? Maybe I understood something in the configuration wrong?

The default service type for the proxy is LoadBalancer:
https://zero-to-jupyterhub.readthedocs.io/en/latest/resources/reference.html#proxy-service-type
You’ll need to change it to NodePort: Service | Kubernetes

Thanks for the pointer, manics. Helped a lot :slight_smile:
For anyone else stumbling here and looking to setup Jupyterhub on k3s with traefik:
I ended up using the following config to configure ingress and service:

ingress:
  enabled: true
proxy:
  service:
    type: ClusterIP
1 Like