Helm UPGRADE FAILED: no matches for kind "Ingress" in version "networking.k8s.io/v1beta1"

Hi all!

I broke my head and can’t find a clue on what’s wrong with helm upgrade procedure.
helm upgrade --cleanup-on-fail --install binder jupyterhub/binderhub --version=0.2.0-n966.h248f390 --namespace=binder -f ./secret.fifo -f config.yaml --dry-run --debug

Returns error:
resource mapping not found for name: “binderhub” namespace: “” from “”: no matches for kind “Ingress” in version “networking.k8s.io/v1beta1

helm template --verify has no reference for “networking.k8s.io/v1beta1” and produces no errors.

K8s cluster: Azure AKS version v1.24.9

current helm chart: binderhub-0.2.0-n611.he777436

Any ideas where helm picking up old API reference from or how to fix it?


Do you also see this error with the latest dev release (1.0.0-0.dev.git.3018.he00ec49)?

Thanks for getting back to me.

Yes, the latest version also produces same error. I’ve tried many different version and getting same issue.

I can’t think of any potential causes. Does it also occur with a new deployment, or only with an upgrade?

Thanks for looking into the issue.
New deployment is working fine. I couldn’t find the issue, so redeployed the jupyterhub.
The only tricky part was migration of user’s data, but I figured it out.

1 Like