File Save Error in R notebook

Getting a file save error after running a cell that views a R vector. Error message:
`File Save Error for 403_test_2.ipynb

403 Forbidden

403 Forbidden

`

To recreate run these two lines in R kernel:

x = c('a','b','c','d','e')
x

Works fine in JupyterLab version 1.2.6. You sure other code works?

I’ve tried other versions and it hasn’t fixed it, but I did find something interesting.

When a vector in R looks like this, I can’t save that file:
Screen Shot 2020-03-18 at 8.51.11 AM

When it looks like this I can:
Screen Shot 2020-03-18 at 8.51.16 AM

The difference is that the first one is more of a production environment with lots of libraries and packages installed on top of r-base using conda/CRAN. Second one is an isolated environment with just r-essential. Same version or R (3.6.1) and same version of JupyterLab (1.2.5).

I’m going to slowly bring in more libraries to my test env to see if one of them causes the issue.

What does the raw JSON for the cells in the notebook file look like?

On the JupyterHub repo someone reported an issue with loading notebooks due to a possible inconsistency between strings vs list of strings:

Your output looks like a single string in the first case and a list in the second so I’m wondering if it could be related.

1 Like

I can only see the raw json of the one that does save, so not sure if that’s going to be too helpful. But I do think it has to do with the single string vs list.