Deploy jupyter notebook for web

I need to deploy a jupyter notebook application, but I need it to run as a web app. I’m using anaconda, so in my Dockerfile I’m pointing to the image of the docker conda. And I’m using voila to make it a web app. But I’m not getting it, because my application breaks, can someone help me or send me a tutorial please?

Hi! Jupyter notebook and JupyterLab are already web applications.

Please could you provide a bit more information on what you want to do? You may find this post helpful:

Helo! I need to create a jupyter notebook web, for other people to access this notebook, but without the part of the code, so that they see only the plots …
so i decided to use voila, but i can’t deploy to heroku.
When I used only pip packages, it worked. but I used fbprophet and fbprophet doesn’t work well with pip, so I used the conda.
in short, I need to deploy my application so that it can be accessed by a URL.
Sorry my English, I speak Russian. : /

You can use conda with Voila, too. If you go to the Voila gallery project, and click on the ‘render-stl’ box, you’ll get a session for Voila. (You can get back the the Dashboard from there by changing the URL. You delete voila/render/index.ipynb and rest of text to the right and replace that with tree. From there you can get to the index.ipynb notebook.) The environment for that is dictated by environment.yml. That gets built by conda. I suggest you fork this repo and add your conda packages to your forked environment.yml, and then use an adjusted link to launch your session from your new repo. (The links I have in the markdown code here may help you in seeing how you construct those to your Trying that may provide you with some feedback as to whether your packages get installed with no issues, independent from your own system. It should at least give you an idea of what you may need to troubleshoot things on your own server.

Also, appmode works with conda. See last section here. You may have better luck using that where you are trying to host?

1 Like

I’m trying to host on Heroku… I even managed it with buildpack’s, but It went over the 500MB limit, so I decided to use docker. But I could not…
I tried to use Binder, but the link generated was temporary and every new user who opened the link had to wait for the deployment again…
I will try to follow what happened to me, thanks for the reply.

If you post a link to your repo, I can advise on the Binder stuff.
The launch process for Binder shouldn’t take too long once it is built. Every time you push a change though the build will be required again. You can try the links I sent you for examples of how to construct the proper link. That will give you a sense of how fast the session spinning up should be and the time to see your Voila app.

1 Like

Thanks!!! :smiley: After following the tutorial it worked

1 Like