Cqant open new notebooks in notebook

I have run into an issue where I get the basic webpage and can log in.
but when i try to create a new notebook it sends me to a blank page and it seems to freeze trying to open the new notebook. Any help would be great.

Sure i start jupyter notebook with this command
jupyter notebook --debug --notebook-dir=/data/projects --port 8989the other

then I ssh -L 8989:localhost:8989 .

Then in my browser i open localhost:8989 and I see jupyter notebook and I can log in.

Then when i go to new notebook python3 or any of the other choices for a new notebook the system seems to stop and a blank page opens in the browser but itnever turns into a notebook page. when i look at the debug info it doesnt say anything is just sticks at creating new notebook

[I 13:38:40.042 NotebookApp] Creating new notebook in
[D 13:38:40.044 NotebookApp] Saving /data/projects/Untitled.ipynb

You say you ran into the issue. Was it working and it stopped working? Or is this a completely new install on the new remote machine?

Maybe you don’t have permissions on the remote machine where it is trying to save the file and so it hangs?

You say you cannot make a new notebook. What happens when you try to open an old one?

Unlikely, but I’ll also ask:
There’s no errors showing up in the browser developer tools when you try making the new notebook?

Yes it was working then we upgraded the system o rhel 8 and it stoped. I upgraded juypiter and ipython and python3, i have tested to see if its a permissions issue but it doesnt seem to be i created a folder with totally open permissions and used it as the
notebook directory on the home drive which is not not a mounted drive like nfs and it still hung up at the start a new notebook. Nothing happens when I tried to open a old notebook either, it opens a blank page on the browser but even in debug all it shows is starting a new notebook.

Did you do all the upgrades of Jupyter, IPython, and Python the same way you originally installed them? I think someone else pointed out people had mixes of tech after such updates recently. But in that case it was more of an indicative error than you are seeing, if I I recall properly.

It happened when the system was upgraded though, first? Are you sure that didn’t mess up what ports were open or in use? I would expect the login wouldn’t work though if that was the case though, and so probably isn’t that. I’m casting around because I wish there was more to go on in sorting this out.

Have you tried a new browser? Turned off browser extensions? Cleared the cache? Tried connecting from a different computer? Tried the exact IP number in the URL and not localhost (idea based on here)?

After you log in to Jupyter, does the Jupyter terminal work and editing text files and using the file browser?

Tried removing the config folder: ~/.jupyter/, see here

Here is the version of the apps

jupyter --version
Selected Jupyter core packages…
IPython : 5.1.0
ipykernel : 5.5.6
ipywidgets : 7.8.1
jupyter_client : 7.1.2
jupyter_core : 4.9.2
jupyter_server : not installed
jupyterlab : not installed
nbclient : 0.5.9
nbconvert : 6.0.7
nbformat : 5.1.3
notebook : 6.4.10
qtconsole : 5.2.2
traitlets : 4.3.3

I tried uninstalling everything then upgrading. I tried different locations and pertmissions and moved the .jupyter folder so it would create a new one. So far nothing has worked.

How exactly are you installing and upgrading?
Ummmm… you have no jupyter_server? And if you upgraded, I’m unclear how you are getting Jupyter Notebook 6.4.10 and no Jupyter_server?!? You seem to be trying to use old tech. And incompletely perhaps.
I’d check out:

I’d suggest you may want to consider using NbClassic since you don’t want to use JupyterLab and seem to be focused on using the older Jupyter Notebook UI. (Although maybe that wasn’t on purpose?)

Here is the version list now

IPython : 7.16.3
ipykernel : 5.5.6
ipywidgets : 7.8.1
jupyter_client : 7.1.2
jupyter_core : 4.9.2
jupyter_server : 1.13.1
jupyterlab : 3.2.9
nbclient : 0.5.9
nbconvert : 6.0.7
nbformat : 5.1.3
notebook : 6.4.10
qtconsole : 5.2.2
traitlets : 4.3.3

It still doesnt creat new notebooks. I updated everything by uninstalling it all then using pip to install jupyter notebook and jupyter lab it moved the rest over. I also moved the users .jupyter files to a back up folder and renamed them.

Do I see python3 notebook in the new menu but when i connect to it i just get a blank browser window and the app shows Saving ipynb file.

I was hopeful using new tech would offer at least something but a blank page.

If you look at the HTML source code for the blank page, does it indicate any content even if it isn’t displaying?

Have you tried a different computer on a different network? While I would think though since the login screen comes up, it isn’t the port being blocked, maybe checking ffrom another computer would shed some light?

No, i looked and its just a blank page. Do any of the versions look old compaired to the others.

Your JupyterLab definitely looks old, as well as your ipykernel & traitlets. Here is what I see for one of the main current mybinder.org offerings:

IPython          : 8.12.0
ipykernel        : 6.22.0
ipywidgets       : 8.0.2
jupyter_client   : 8.1.0
jupyter_core     : 5.3.0
jupyter_server   : 1.23.6
jupyterlab       : 3.4.8
nbclient         : 0.7.3
nbconvert        : 7.3.0
nbformat         : 5.8.0
notebook         : 6.4.12
qtconsole        : not installed
traitlets        : 5.9.0

I’m more worried about stuff that gets left behind though when you run an upgrade. That stuff can interfere in odd ways. Although, I’d expect an error somewhere (?!?!). That’s the really weird thing in all this.

I update to python3.9 and then upgrade jupyter notes and now im at

IPython : 8.18.1
ipykernel : 6.28.0
ipywidgets : 8.1.1
jupyter_client : 8.6.0
jupyter_core : 5.7.0
jupyter_server : 2.12.2
jupyterlab : 4.0.10
nbclient : 0.9.0
nbconvert : 7.14.0
nbformat : 5.9.2
notebook : 7.0.6
qtconsole : 5.5.1
traitlets : 5.14.1

I still get this from the new window now

Jupyter Notebook - Notebook

It is no longer blank. At least we are making progress.

Is JupyterLab working at all?

Jupyter lab comes up the only issue continues to be when i try to open a notebook it freezes with

Creating new notebook in
[D 2024-01-05 11:52:09.769 ServerApp] Reading path from disk:
[D 2024-01-05 11:52:09.769 ServerApp] Reading path from disk: Untitled.ipynb
[D 2024-01-05 11:52:09.796 ServerApp] Reading path from disk: Untitled.ipynb
[D 2024-01-05 11:52:09.796 ServerApp] Saving /pollard/data/projects/jlee/Untitled.ipynb

Sorry that reply was unclear. JupyterLab works well or that cannot create a new .ipynb file either?

Sorrry, yes i can open and log into jupyter lab but it cant seem to create or open notebooks I.E the ipynb files.

Until you try to open or make a new .ipynb file, JupyterLab otherwise looks and behaves well?

yes it behaves, i can look at the directories i just cant open or create .ipynb files.