Could not log into Jupyterhub. Auth cookies problem?

Hi everyone,

I’m running a Jupyterhub instance installed from anaconda repository. These are the relevant component versions:

jupyter_core 5.3.1
jupyter_server 2.7.0
jupyterhub 4.0.1
jupyterhub-base 4.0.1
jupyterhub-ldapauthenticator 1.3.2
jupyterlab 4.0.3
jupyterlab_server 2.24.0

I’m using ldapauthenticator as authenticator backend.

I’m facing a problem with a current logged session. Once the credentials are entered on the main page to authenticate, it keeps loading and the animated icon spinning continuosly but never manages to log in. Tried with different browsers and private tabs as well.

The syslog shows the (apparently related) logs:

[…]
Token stored in cookie may have expired
Couldn’t authenticate WebSocket connection
Token stored in cookie may have expired
wrote error: ‘Forbidden’
[…]

It does not happen always and not with all the users.

Any ideas?

Thanks in advance!

quick update.

I killed all the processes and the user is able to log in again. However the logs messages mentioned above still appear. So they have nothing to do with the log in issue.

any ideas why the log in process got stuck or how to troubleshoot it?

Can you clear cookies and login again? That may help.

I did. Same result. Even from a private tab

Can you check the version of jupyterhub in both the hub env and the user env, and share the hub logs when the rejected token is checked?