Can't open notebook on Mac Anaconda install?

Hello. After installing the notebook using Anaconda, I encountered the following error message

[W 2021-12-01 10:09:59.940 LabApp] 'browser' has moved from NotebookApp to ServerApp. This config will be passed to ServerApp. Be sure to update your config before our next release.

[W 2021-12-01 10:09:59.941 LabApp] Config option `kernel_spec_manager_class` not recognized by `LabApp`.

[W 10:09:59.970 NotebookApp] No web browser found: could not locate runnable browser.

To access the notebook, open this file in a browser:

After paste the address in a broswer, it produces kernel error:

File "/Users/myname/opt/anaconda3/lib/python3.9/", line 1821, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)    
FileNotFoundError: [Errno 2] No such file or directory: '/Users/myname/anaconda3/bin/

My anaconda is installed in ~/opt/anaconda3/, while the file seem to search ~/anaconda3. Tried re-install everything, still got the same problem.

You seen this post and the ones after it, such as this one. Tried that?