Cannot start RStudio in Binder

I have this Binder Repository:

It has run without issues for a couple of years.

However, when I tried this week, I keep getting:

The error was:
500 : Internal Server Error
could not start rstudio in time

I have tried all sorts of ways: using a Docker, no Docker, and several things.
I am using an apt.txt file, an install.R and a runtime file.

Even if I enter to the Jupyter lab interface and I try to open the Rstudio from there, it fails with the same error. I am a bit lost here.

Adding Docker in the repo shouldn’t be needed. Did somewhere or something recommend that?

If you seem to have changed a lot of stuff recently and so it is hard to diagnose at this point. The easiest at this point would be to make a new repo using the example ’ Specifying an R environment with a runtime.txt file’ as a template and then modify it step-by-step with additional things in your Workshop software dependencies and see when it breaks. For instance, start with a runtime content/setting that works to get RStudio. It may break right away with the template as the service has been rocky. However, then you’d know it isn’t anything in your control. The current example there launches and RStudio works.

1 Like