I cannot complete a development install as described in theme’s README.md:
For a development install (requires npm version 4 or later), do the following in the repository directory:
npm install jupyter labextension link .
Here are the steps to reproduce:
$ cookiecutter --no-input https://github.com/jupyterlab/theme-cookiecutter $ cd mytheme $ npm install npm WARN deprecated @firstname.lastname@example.org: This is a stub types definition. handlebars provides its own type definitions, so you do not need this installed. npm WARN deprecated email@example.com: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools. npm WARN deprecated firstname.lastname@example.org: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1 > email@example.com install /Users/ynkt/tmp/mytheme/node_modules/fsevents > node-gyp rebuild SOLINK_MODULE(target) Release/.node CXX(target) Release/obj.target/fse/fsevents.o SOLINK_MODULE(target) Release/fse.node > firstname.lastname@example.org prepare /Users/ynkt/tmp/mytheme > npm run clean && npm run build > email@example.com clean /Users/ynkt/tmp/mytheme > rimraf lib && rimraf static && rimraf tsconfig.tsbuildinfo > firstname.lastname@example.org build /Users/ynkt/tmp/mytheme > tsc npm notice created a lockfile as package-lock.json. You should commit this file. npm WARN email@example.com requires a peer of bufferutil@^4.0.1 but none is installed. You must install peer dependencies yourself. npm WARN firstname.lastname@example.org requires a peer of utf-8-validate@^5.0.2 but none is installed. You must install peer dependencies yourself. added 995 packages from 1767 contributors and audited 19060 packages in 20.942s found 7 vulnerabilities (1 low, 4 moderate, 2 high) run `npm audit fix` to fix them, or `npm audit` for details $ jupyter labextension link . An error occured. ValueError: "email@example.com" is not compatible with the current JupyterLab Conflicting Dependencies: JupyterLab Extension Package >=1.2.1 <1.3.0 >=2.0.0-beta.2 <3.0.0@jupyterlab/application >=1.2.1 <1.3.0 >=2.0.0-beta.2 <3.0.0@jupyterlab/apputils See the log file for details: /var/folders/43/14qb6f816gn4sgy_cz5p1l4h0000gn/T/jupyterlab-debug-mli3qapc.log
I know what JupyterLab is complaining about. What I don’t understand is where
>=1.2.1 <1.3.0 (or possibly
~1.2.1) comes from. Version 2.0.0-beta.3 is installed for both dependencies, and this is compliant with
How can I fix this error and start previewing my theme?
FWIW, the output of
jupyter --version is as follows:
$ jupyter --version jupyter core : 4.6.1 jupyter-notebook : 6.0.3 qtconsole : not installed ipython : 7.12.0 ipykernel : 5.1.4 jupyter client : 5.3.4 jupyter lab : 1.2.6 nbconvert : 5.6.1 ipywidgets : not installed nbformat : 5.0.4 traitlets : 4.3.3