Busy kernel in tljh notebook

Hello all,
I have installed The Littlest JupyterHub on ubuntu 18.04 server. Followed the instructions on tljh website and all went well. I can access the hub and create a notebook that successfully connects to the python kernel.
The only issue is that it does not output when I run a simple script and it shows the [*] after each run. Tried restart, interrupt and reconnect with no success!

Any suggestion would be great!
Thank you,

Does really simple code such as 2 + 2 run and give you a result?

No, it just creates a new cell with [*] in the preceding cell that contains 2 + 2.

Thank you,

You cannot get simpler than that code. Hmmm…

Was the install on your own server or one of the cloud providers in the list?

1 Like

Thanks fomightez for your reply.
I am using my own ubuntu server 18.04 and followed the instructions at:


Have you examined the ‘User Server Logs’ for the user account (I assume yours) where you are trying to run the notebook that seems to hang? See here.

If you launch a terminal instead of a notebook, can you type python and run code there?


Python runs fine in both ubuntu and jupyter terminal.
Thanks for the suggestion. My logs shows all is good until certain modules are called under tornado and the interpreter crashes!

Here is my log information:

Can you check your browser’s JavaScript console for any warnings or errors when loading or running the notebook?


I checked both firefox and chrome under windows and linux, the JS console had no issues.
I decided to reinstall both ubuntu server and tljh and it is all good now.
I am not sure what changed in this process but I am assuming some packages were broken when I first downloaded tljh.

Thank you fomightez and manics for your kind help.


1 Like