Blocking issue with pandas_datareader in Anaconda - "conda install -c anaconda pandas-datareader" not fixing it

I have a blocking issue with pandas_datareader (Windows) installed with Anaconda/Jupyter. The solutions proposed in other StackOverflow posts are not working as following described.

This is a simple code for testing the datareader package

import pandas as pd
import numpy as np
from import DataReader

and this is the error I get

ModuleNotFoundError                       Traceback (most recent call last)
Input In [1], in <cell line: 3>()
      1 import pandas as pd
      2 import numpy as np
----> 3 from import DataReader
ModuleNotFoundError: No module named 'pandas_datareader'

As suggested in other Q&As in StackOverflow I manually installed the datareader package with this command

conda install -c anaconda pandas-datareader

The process seemed to be completed successfully; as further verification, if I try to re-install it, I get a notification saying that “# All requested packages already installed.”

I have tried to restart the kernel and also rebooted the system. The trouble is still there. I have also uninstalled pandas_datareader (“conda uninstall pandas-datareader”) and reinstaleld it. Nothing.

A further investigation leads me to this last result

  • “pydoc modules” console command lists the pandas_datareader properly
  • “conda list” console command lists the pandas_datareader properly
  • in Jupyter the command “help(“modules”)” does not list the pandas_datareader package

and this might be the problem something strictly linked to the use of packages through Jupyter. Any idea?

Perhaps try the %conda magic:

%conda install pandas-datareader

This takes a few extra precautions to make sure your packages get installed in the correct environment.

hi and thank you. I found another “solution” that worked for me; in Jupyter notebook I lunched these commands