Binder does not start, logs are empty

help my binder not work what can i do?

Share the git repository, screenshots, logs etc. so that people can understand the underlying problem.


Can you provide the link to the repo please?

i try to open this repo but i can’t

The “launch binder” button in the repo just worked fine for me?

in this case. my binder steel spinning about an hour. i don’t know why?. is any setup requirement or sign up to anywhere?

Ah, there’s no logs. Do you have an ad-blocker running? If so, please disable it and try running again. Give the page a few refreshes until text appears in the black box below “build logs”.


I disable the ad-blocker. and it lunch but when I try to re-run the same repo but it’s don’t lunch again. besides, I try to run it on firefox and it’s run fine. is any problem with the chrome browser?

We currently have no reports of issues launching on Chrome. Can you please try to refresh until logs appear and we will investigate why this is happening. Thanks.

cc/ @betatim

1 Like

Thank you so much for your help. i will notify if having faces any problems.

1 Like

I have run in to this from time to time. I don’t know if it Chrome-specific because I generally use Chrome and then only use anything else when I encounter this problem. Rarely, on a failed launch like you experienced something gets so messed up somewhere on your machine that launching in that browser from that particular repo won’t work for the near term. I don’t know if it is caching or something else(?). What you have done by using another browser seems to be a reasonable work around. Sometime I try on a different computer or device (iPad) to see if it is just my browser. And then usually in a few days it works itself out. (I’ll add that I also never tried as a work around launching with a different URL, such as a specific commit; however, I wonder if that would circumvent the issue.)

Really, days?! I usually refresh 2-3 times and then the log appears :confused:

When it gets in that state, I refresh the heck out of it with no luck. That is why @imrankhan_binder 's description I quoted above struck a chord with me.
Well, I’d say it will take at least a few hours if not days to work itself out. I used to go home from work at the end of the day, and so I’d try the computer a day or two later. And it is so rare I haven’t had a lot of opportunities to experiment with it.
Especially since I am usually trying to do something else when it arises and so investigating isn’t my priority.
Luckily, I haven’t experienced it lately.