After upgrading kubernetes version, autohttps pod init problem


My jupyterhub was deployed on DigitalOcean.
It was working fine.
After upgrading kubernetes version, I could not access the application.
I tried to redeploy it. I have a problem now.
The problem is autohttps pods do not initialiaze. I have this in the logs

defaulted container “traefik” out of: traefik, secret-sync, load-acme (init)

Error from server (BadRequest): container “traefik” in pod “autohttps-77568dd6fc-schmb” is waiting to start: PodInitializing

I read a workaround about this and try to add this in config file:
- name: startup-delay
image: busybox:stable
command: [“sh”, “-c”, “sleep 10”]

Now, it says

Error: UPGRADE FAILED: values don’t meet the specifications of the schema(s) in the following chart(s):


  • proxy.traefik: Additional property extraInitContainers is not allowed

Your help is very much appreciated.


Are you using the latest release of Z2JH? If not can you give that a go?

No, I am not using the latest release oof Z2JH.
There is a part in my config for the customisation of hub like this below
- name: git-clone-templates
image: alpine/git

This part doesn’t work with the latest version of jhub.

That explains the

then, since the property was first released in Z2JH 2.0.0.

2.0.0 also contains several other bug fixes and improvements so I recommend upgrading.

Thank you for your recommendation.
I suppose I have to do this customisation in docker for the hub in order to use the latest jub version.
Only I don’t know which directory, files to update.
I will look for it.
Thanks again

Hi @Marvel_Tales, do you find the solution for this? We encounter the same issue after Digital Ocean update the k8s. Where do you find the workaround you posted?


No, unfortunately I could not fiind the solution for this.
There may be a solution if you also update the versions of whatever you use to the latest versions in your development. In my case, I did not have time to work on it.

So, I destroyed the kubernetes cluster on digitalocean and moved the application to google cloud.Without changing any configuration or docker versions, the deployment worked on my first try on google cloud.

Thanks for your interest.