Which environment does '%%bash' cells run in Jupyter for Windows launched from base env via Anaconda Prompt (PowerShell)?

Hi, all! First time writing - hopefully in the correct category.

Im running through a tutorial notebook, and ran into problems when executing a !aws command via the notebook. This command also aggregates some information with grep command (!aws … | grep …).
I tried installing m2-base to introduced grep to my current environment, although the notebook shell does not recognize the grep command.
I thus tried to run the cell with the %%bash-magic, however now it does not recognize the aws command.

I’m starting the JupyterLab session from my base environment via a PowerShell Anaconda Prompt. And the notebook session is running a kernel from a prefixed virtual conda environment in my project directory.
There is quite a lot of shell commands in this notebook, as it is written for tutorial purposes, and manually translating each command is hopefully not the preffered solution.

Many thanks for any kind of help =)