Problems when running Julia on JupyterLab

I haven’t heard of this. Is there a JupyterLab issue already opened for this?

I usually explicitly request a version pip install jupyterlab=2.1.2 to make sure, or I think you can use --upgrade.

Hi. Thanks for the suggestions. Neither of those work. Unfortunately, my conda is totally broken (which is why I am using pip even though I heard you are not meant to mix - I have nothing to lose at this point!!)

As for the ‘blank screen’ issue, I typed ‘JupyterLab blank screen’ on Google and got pages and pages of hits, including

I think your trying to chase bugs is admirable, but might be a losing battle until they develop some standalone installation scripts for JupyterLab

These are about JupyterLab itself not showing up. Is that what is happening to you? I.e., you type “jupyter lab” and just a blank webpage shows up (no JLab ux, etc.)? In my experience, these are usually installation problems. The one you list is more about configuring JupyterHub to use JupyterLab rather than a problem in JupyterLab itself, which sounds like it is very different from your situation.

I thought you said you could open a file, which indicates you are seeing JupyterLab, but for some reason the editor doesn’t show text.

I’m a core JupyterLab developer :).

Given that you are having issues with your conda/python environment and it may be broken, I’m curious if using a fresh clean environment gives you a working JupyterLab 2.1.2.

Thanks. I haven’t used python in a long time and don’t remember many details about environments. I guess I have to set up a new environment reinstall python and conda, then try to install JL, and make sure I have activated the environment whenever I start JL. Isn’t that right? Seems like a very roundabout way just to get a Julia IDE running…I may stick with my clunky emacs shell for now and keep an eye on developments. Thanks, though!

If you are using conda, it may be as easy as:

conda create -n MyNewEnvironment -c conda-forge jupyterlab
conda activate MyNewEnvironment
jupyter lab

Hey, thanks - that worked - sort of. I managed to install JupyterLab 2.1 but the ‘right-click’ still doesn’t work in the editor, so I can’t get console on the same page as the editor. It does switch back and forth faster, though!
Is there any way to get the console and editor on the same page without using ‘right-click’? PS Tried both Firefox and Chrome - no ‘Right-click’
[Reminder: this is Ubuntu 18.04]

Hi Jason,

More bad news, I’m afraid. With the new (updated) version, ‘paste’ (CTRL-V) does not seem to work in the editor anymore, although it does in the console. This was not an issue in the earlier version before I upgraded.

Just to remind: This is on the Ubuntu machine: I cannot right-click and pasting does not work.

On my MAC I cannot see my files when I open them up in the editor - I just get what looks like empty files (although they run).

Seems like lots of bugs still – it can’t be only me.

I think I need to leave this. I’ll try again in 6 months and see if you have gotten further [I need to get back to work!]

It would be handy if it worked.

Thanks for trying. These are indeed puzzling, and I don’t remember hearing of these issues before (ctrl-v not working in the editor, not seeing the right-click menu, not seeing text content when opening a file). They seem pretty egregious and noticeable, so I’d be very surprised if they were widespread.

Sometimes people have posted about very odd behavior happening in older browsers, or browsers with extensions that changed the page structure. It’d be a great help if you could post:

  1. The browser and browser versions you are using
  2. What JupyterLab extensions you may have installed: jupyter labextension list
  3. Do you see any errors in the browser javascript console
  4. Do you see any errors in the server console (where you launched JupyterLab)

Edit: I see above you said you tried both Firefox and Chrome on Ubuntu 18.04 for the right-click. I assume the latest versions of those browsers?

Edit 2: And I understand if you don’t have time to try to debug this further. It’s just really puzzling to me the symptoms you are seeing, so whatever debugging information you can post will help narrow down if the problems are with your installation or with JLab itself.

That’s what I posted above about dragging the tabs (watch the first 16 second video at that link to see a demo of dragging tabs)

I am using Firefox 76

@compleathorseplayer, tell me, is the Jupyter runtime and editor running native on your Mac? That is, are you connecting to JupyterLab over

– Rick

Yes, as localhost. I finally figured out the issue: using ‘WhiteListing’ ad-blockers (particularly mu-blocker) is not good enough - you have to fully disable them, it seems, for JL to work.

Thanks and sorry for not figuring this out sooner!

Glad it worked out for you, and I’m sorry I didn’t post a response sooner.

I’m really curious to see if this would be a problem on Cloud-hosted solutions, like our own, and I want to test it. Can you tell me the steps to reproduce and I’ll try it out on our free hub?

Or, for that matter, did you have this problem using JuliaBox?


To recreate, try using mu-blocker - quite a nice ad-blocker, but problematic here for me.

Was it mublocker or uBlock? I have the latter installed on Chrome, and Julia works just fine for me in the cloud…

Maybe ublock (sorry)
I was using Firefox.

Thanks, David. I just tried it on the cloud service we run, and both a Julia console and Notebook work fine, file tree is updated, etc., with uBlock running on Firefox and no whitelists. It’s odd – I can’t think why uBlock would be sensitive to stuff coming in over and not from Google Cloud Engine.

– Rick

Dunno - just that once I disabled this, my problems went away immediately.
Please note I am on the Mac (not on Linux like your servers) so there could be something different in the way it works. Took me the longest time to resolve, though. Anyway, thanks!

I’m getting the same thing on my Linux (Ubuntu) version - I open up a (non-empty) file and the editor shows it to be empty (blank).

I have had to drop this - it is just not ready
PS I am not running any ad-blockers on this server