JupyterJupyter server process exited with code 133 rosetta error:

/Users/admin/.conda/envs/ml-101/bin/python -m jupyter notebook --no-browser --notebook-dir=/Users/admin/Desktop/projects/ml-101
rosetta error: /var/db/oah/279281327407104_279281327407104/438da966fff0f6aab18d0627f2bbe82fd8ee21e6e49e22d47a887298bfb7e97e/libmkl_rt.1.dylib.aot: attachment of code signature supplement failed: 1

I’m getting the above error trying to run Juypter it worked flawlessly until today. I tried to completely purge all instances of Juypyer and dependencies as well a full purge of conda environment and packages and start from scratch however it’s still throwing this error so I’m not sure what to do. I’ve tried running it using rosseta terminal but it still throws the same issue.

I’m on a M1 MBP.

/Users/admin

Please don’t run conda (or pip or npm or gem) as root/admin.

libmkl_rt

mkl is a heavy-duty math library, and should not be needed to start notebook. Do you have lots of serverextensions installed? Have you tried removing them?

Also, if you’re using the *naconda distribution (and therefore the defaults and/or *naconda channels)… you’ll probably need to check their forums.

Given the above, here’s a troubleshooting approach:

  • start with miniforge
  • make a new environment
name: my-test-environment
channels:
- conda-forge
- nodefaults
dependencies:
- notebook
- python >=3.10,<3.11
# - other-package
  • keep adding a package at a time until it breaks
  • when it breaks, run conda list --explicit
  • when you get there, go search for related issues on

    https://github.com/conda-forge/<broken-package>-feedstock

    • if there aren’t any, make a new one
1 Like

I’m not running it as root/admin I just replaced my username with admin text since my username is firstname + lastname :smiley: I’ll try your suggestion, tho I don’t really have any server extensions installed just plain jupyter.