Installing Jupyter Lab on Restricted (Work) PC with limited read/write access

I’m struggling to get Jupyter Labs working on my work PC where i have limited control over what folders i have read/write access.

I have been using jupyter notebooks fine (was installed with python by an application manager that bypasses read/write access).

I have to install python modules/packages to a specific target folder in my documents where i have read/write access and then point notebooks to this in the path when starting up via a shortcut.

When i tried to install Jupyter Labs, i specified this folder for installation and it seemed to install fine (it even updated my notebook version to the latest version 5.x).

However when i try open jupyter lab i get errors:

  • if i try typing jupyter lab from the cmd i get “Error executing Jupyter command ‘lab’: [Errno ‘jupyter-lab’ not found] 2”. I also get this error when running jupyter lab build

  • if i open my notebook and change tree to lab in the address bar i get

JupyterLab Error
JupyterLab application assets not found in “C:\Program Files\Anaconda3\share\jupyter\lab”
Please run jupyter lab build or use a different app directory

if i try run build i get the same error as above (jupyter lab not found)

if it helps my lab is installed here where i have read/write access:
‘C:\Users\myworkusername\Documents\PythonLibraries\jupyterlab’

and anaconda3/python are installed here:
C:\Program Files\Anaconda3
C:\Program Files\Anaconda3\python.exe

Any tips how best to install labs/get labs working? Is it possible to specify where its installed when opening? Or another solution for users with limited read/write access?