Cannot get R project working

Hi, newbie here. When I try to start my binder with R using either install.R or DESCRIPTION I get an apt-get error below:
The following packages have unmet dependencies:

 r-base : Depends: r-recommended (= 3.6.1-3bionic) but 3.6.2-1bionic is to be installed
          Recommends: r-base-html but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Removing intermediate container 7aa83b36947a
The command '/bin/sh -c apt-get update && apt-get install --yes r-base=3.6.1-3bionic      r-base-dev=3.6.1-3bionic      libclang-dev && apt-get -qq purge && apt-get -qq clean && rm -rf /var/lib/apt/lists/*' returned a non-zero code: 100
1 Like

I suspect you are referring to this repo?

I separately paralleled the runtime and install file you used (assuming the repo I pointed at above was indeed the issue) and was finding it works, see here. Then I tried yours from that repo above and it worked too. However, upon further testing mine suddenly stopped working without me re-committing and I saw that exact error you reported. I tested some more and I am fairly confident at this point it is an issue with where these R-based repos are getting built/launched in the public Binderhub federation. I’ll privately send you a work around if you’d like while I try to discuss it with the MyBinder folks.

1 Like

I have exactly the same issue

Temporary work-around sent to @flor and the build has been confirmed to work.


I’ve got exactly the same issue.

Could you please send me a workaround.


Temporary work-around sent to @SoftFact and the build has been confirmed to work.

Hi, also new to binder and running into the same issue with either the install.R or DESCRIPTION file options. Would you share your work-around? Thank you!

Temporary work-around sent to @ablucher and the build has been confirmed to work.

In regards to this discourse post, I had endeavored to send the temporary work-around to @kozo2; however, it appears the Binder federation member server I was using as a work-around has been updated now and fails to build.

I am going to update the Github issue I posted about this with the current information.

I also have the same problem with respect to the following github repo:

For R-based notebooks and RStudio based ones, I think I may have a new work-around to offer. The install.R file will still work; however, you have to switch to using a Dockerfile instead of runtime. Example work-in-progess is here . However, @aciobanusebi , it doesn’t seem to work with RShiny .

this should now be fixed with the latest deploy to, let me know if this works for others now!

1 Like