Build fails while collecting package metadata

I’ve been following the contributing instructions to get BinderHub running with minikube, but I run into a failure during build, right after this log output:

+ conda env create -p /srv/conda/envs/notebook -f /tmp/environment.yml
Collecting package metadata (repodata.json): ...working...

With debugging enabled I see a 404:

[D 191203 15:39:23 rest:219] response body: {"kind":"Status","apiVersion":"v1","metadata":{},"status":"Failure","message":"pods \"build-xxxxxxxx-e8225e-d93d43\" not found","reason":"NotFound","details":{"name":"build-xxxxxxxx-e8225e-d93d43","kind":"pods"},"code":404}

I encounter the same problem on macOS and CentOS, so I’m clearly doing something wrong in both places. Is there some step here that I am missing? Many thanks for your help.

Could you give a bit of detail where the second bit of log output came from? I suspect it is from the binderhub pod but unsure.

What is it that fails in your build? What repository are you trying to build?

+ conda env create -p /srv/conda/envs/notebook -f /tmp/environment.yml
Collecting package metadata (repodata.json): ...working...

by itself doesn’t look wrong, it should print some kind of error that could point towards what exactly isn’t working.

I think there’s something more fundamental wrong my installation. When I run pytest -svx -m "not auth_test" I get an error on JupyterHub’s availability, i.e. JupyterHub available at ERROR

I was able to get JupyterHub running fine using the Zero to JupyterHub instructions (and using minikube tunnel to handle the LoadBalancer), but it seems like JupyterHub is not accessible when I try to follow the binderhub/minikube testing instructions.

OK, I never see an EXTERNAL-IP when running kubectl get svc proxy-public -n binder-test. This seems like a problem? Any ideas how to fix this? I’m running minikube on macOS.

Can you create a short step by step list of what you did since downloading minikube?

For me following the instructions “just works”. I never used minikube tunnel so maybe the fact that you think you need to use it points towards there being a difference in how minikube is configured? Things to check in addition to a list of the exact step by step commands you run is what minikube ip says. Once JupyterHub is up you should be able to reach it at http://<minikube ip>:30123 (open it in a browser and it should show some kind of Jupyter themed error page)

Thank you for responding. After adding c.BinderHub.debug = True to, I followed these steps:

curl | bash
helm init
helm repo add jupyterhub
helm repo update
python3 -m pip install -e . -r dev-requirements.txt
eval $(minikube docker-env)
python3 -m binderhub -f testing/minikube/

When I visit http://<minikube ip>:30123 I get redirected to http://<minikube ip>:30123/hub/login and receive a Jupyter-themed “403 : Forbidden”.